Forum General Discussion Android Phone notification Issue

This topic contains 7 replies, has 4 voices, and was last updated by  okater 1 day, 19 hours ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #260889

    stu old
    Participant

    I have recently purchased my first Reolink. An Argus 2.

    Everything works well except when a Notification occurs, my phone will only alert me if it is awake.
    I still receive an email alert, but this can take time.

    I am using a Huawei Mate 20 Pro with all latest firmware.

    Can anyone help solve this ( and advise if I need to move to a different group)

    Many thanks.

    Stu

    #262470

    Carl
    Keymaster

    Alert notifications may sometimes have a delay, which is normal. May I know what does awake mean? You will also receive the notification even if you turn your phone into silent mode, but it will not make a sound. It will display as notification banner on the screen.

    #262606

    Crimp On
    Participant

    My understanding is that notifications are processed differently be each mobile device (phone, tablet, Apple, Android, etc.) and even differently by version of operating system on the device. So, Carl’s question is critical. Under what condition are alerts not making a sound: (a) when the phone is on but the screen is locked? (b) when the phone is on, but is “asleep” or set to “do not disturb”? Exactly which phone is this?

    #262916

    stu old
    Participant

    Thanks for the replies.

    I am using a Huawei Mate 20 Pro (as above)
    I would only get the notification if I pressed the power button to wake the screen from “sleep”
    It would not wake on it’s own accord.
    The phone is on, set at normal (not do not disturb)

    #262940

    Crimp On
    Participant

    OK, Android phone. Just to be clear, “Do not disturb” means “I do not want to be bothered now.” The phone shows nothing, makes no sound, etc. I use this setting ONLY when at the movies and after I go to bed at night.

    My Android Pie has a number of settings which control notifications. For example, under Lock screen preferences there is a setting for “Wake screen when you receive notifications.” I think this is a phone issue, and not a Reolink issue. Notifications are handled differently by each release of Android, and differently between manufacturers.

    #263006

    Carl
    Keymaster

    Yes, this may be related to the settings of your phone. We suggest you log in this camera on another phone and see if the notification will alert you normally. If it still can’t alert you normally, could you please send an email to support@reolink.com? Our support team will check it for you soon. Thanks.

    #263697

    stu old
    Participant

    Thanks.

    I have been testing this on my Ipad as well and there are definitely differences to alerts from time to time.

    I tested the phone on lte and wifi, ipad on wifi only.
    If the App was open, and the phone was off (I have read a bit about Android Doze) then there were some delays to notifications on the Phone. iPad was fine pretty much all the time.
    I have tried taking steps to mitigate what Doze does to notifications.
    https://developer.android.com/training/monitoring-device-state/doze-standby

    This is something that could be looked into further, as delays in notifications happening could defeat the purpose of having a camera.

    The delyed notifications come through as soon as the phone screen is woken.

    #264975

    okater
    Participant

    Yeah. There are definitely some problems with notification.
    I have 3 «Argus 2» installed.
    Usually it just not working not on my phone nor my wife’s.
    Sometimes it works, usually when the App is open when PIR triggered.
    I think sometimes it worked on faded phone when the App was opened not long ago.
    It is not critical option for me though and I didn’t experiment much with that. But maybe I’ll check it later.

    OS: Android 8
    Location: Ukraine

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.